Roll over image to zoom in · Click to see full view
Product information
From the manufacturer
About this product
- 150 W PoE Budget: 16× 802.3at/af-compliant PoE+ ports with a total power supply of 150 W*
- Full Gigabit Ports: 16× gigabit PoE+ ports and 2× gigabit SFP Slots provide high-speed connections
- Integrated into Omada SDN: Zero-Touch Provisioning (ZTP)**, Centralized Cloud Management, and Intelligent Monitoring
- Centralized Management: Cloud access and Omada app for ultra convenience and easy management
- Static Routing: Helps route internal traffic for more efficient use of network resources
- Robust Security Strategies: IP-MAC-Port Binding, ACL, Port Security, DoS Defend, Storm control, DHCP Snooping, 802.1X, Radius Authentication, and more
- Optimize Voice and Video Applications: L2/L3/L4 QoS and IGMP snooping
- IPv6: IPv6 support with dual IPv4/IPv6 stack, MLD snooping, IPv6 neighbor discovery
Realize More Possibilities with Omada
JetStream 18-Port Gigabit Smart Switch with 16-Port PoE+
Centralized
Cloud Management
Omada SDN Platform Integration
Advanced L2+ Features
L2/L3/L4 QoS, ACL,
Static Routing and More
Abundant Security
Strategies
LAN Area Investment Protection
PoE+ Output
16 PoE+ Ports with
Total 150 W Power Budget
Software Defined Networking (SDN) with Cloud Access
Omada’s Software Defined Networking (SDN) platform integrates network devices, including access points, switches and gateways, providing 100% centralized cloud management. Omada creates a highly scalable network—all controlled from a single interface. Seamless wireless and wired connections are provided, ideal for use in hospitality, education, retail, offices, and more.
Product details
40
| 10G support | No |
|---|---|
| Access Control List (ACL) | Yes |
| ARP inspection | Yes |
| Authentication | MAC-based authentication, Port-based authentication |
| Auto MDI/MDI-X | Yes |
| Auto-negotiation | Yes |
| Basic switching RJ-45 Ethernet ports quantity | 16 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| BPDU filtering/protection | Yes |
| Broadcast storm control | Yes |
| Cloud-managed | Yes |
| Configuring Location Settings (CLI) | Yes |
| DHCP features | DHCP client, DHCP relay, DHCP snooping |
| Ethernet LAN data rates | 10,100,1000 Mbit/s |
| Flow control support | Yes |
| Forwarding rate | 26.78 Mpps |
| IP routing | Yes |
| Jumbo frames | 9 |
| Jumbo frames support | Yes |
| Link aggregation | Yes |
| Loop protection | Yes |
| MAC address filtering | Yes |
| MAC address table | 8000 entries |
| MIB support | MIB II (RFC1213), Bridge MIB (RFC1493), P/Q-Bridge MIB (RFC2674), Radius Accounting Client MIB (RFC2620), Radius Authentication Client MIB (RFC2618), Remote Ping, Traceroute MIB (RFC2925), Support TP-Link private MIBs, RMON MIB(RFC1757, rmon 1,2,3,9) |
| Multicast support | Yes |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3az, IEEE 802.3i, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Packet buffer memory | 4.1 MB |
| Policy-based routing | Yes |
| Quality of Service (QoS) support | Yes |
| Rate limiting | Yes |
| SFP module slots quantity | 2 |
| Spanning tree protocol | Yes |
| SSH/SSL support | Yes |
| Static port security | Yes |
| Switching capacity | 26.78 Gbit/s |
| Switch layer | L2/L2+ |
| Switch type | Managed |
| System event log | Yes |
| VLAN support | Yes |
| Web-based management | Yes |
Logistics
| EAN | 4897098689516 |
|---|---|
| Unit of measure | — |
| Weight | — |
| Dimensions | — |
| Dangerous goods | No |
Warranty
- 12-month warranty on everything we sell.
- Runs from the day your order is delivered.
- Faults under normal use are repaired, replaced or refunded.
Payment
- Visa and Mastercard, processed securely by Tyl by NatWest with 3D Secure.
- PayPal — your PayPal balance or a saved card or bank account.
- Clearpay, Klarna and Billie — pay later or in instalments, processed by Stripe.
- No surcharge on any payment method; refunds go back to the way you paid.
Spread the cost
- 4 interest-free payments of £63.68 with Clearpay. Learn more
- 3 payments of £84.90 at 0% interest with Klarna. Learn more
- Businesses: pay in 30 days on invoice with Billie. Learn more
Choose at checkout. 18+, T&Cs apply, credit subject to status.