‹ Back to products
Brand: Zyxel

GS1900-24HP

Zyxel GS1900-24HP GS190024HPV2-GB0101F

Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Broadcast storm control Yes
Copper ethernet cabling technology 10BASE-T, 100BASE-T, 1000BASE-T
Flow control support Yes
Form factor 1U

About this item

Simple, Fast and Smart Managed Switches for Small Business ConnectivityThe ZyXEL GS1900 Series of 8/16/24/48-port GbE Smart Managed Switch with Gigabit speed and essential managing functions bring your business network more fexibility and connectivity. The 1900 Series consists of eight (8) models—the GS1900-8,...

View full product description

Product information

About this product

Simple, Fast and Smart Managed Switches for Small Business Connectivity
The ZyXEL GS1900 Series of 8/16/24/48-port GbE Smart Managed Switch with Gigabit speed and essential managing functions bring your business network more fexibility and connectivity. The 1900 Series consists of eight (8) models—the GS1900-8, GS1900-8HP, GS1900-16, GS1900-24E, GS1900-24, GS1900-24HP, GS1900-48 and GS1900-48HP. Providing GbE switches with powersaving functions, fanless design and full IPv6 support ensure your network to be ready for future expansions. In addition, the PoE models GS1900-8HP/24HP/48HP Gigabit switch complies with the IEEE 802.3at Power over Ethernet (PoE) Plus standard.

Versatility and fexibility for different needs
The complete ZyXEL GS1900 Series has an essential portfolio of 8/16/24/48-port compact desktop and rackmount size with GbE connectivity. All models support multiple deployment methods to fulfill the needs for small offices and meeting room environments such as wall-, under table- or desktop-mounting and rackmount options. It’s now quick and effortless to enjoy the high-speed business network applications without a hitch. Additionally, the GS1900-24/24HP/48/48HP is equipped with 2 extra SFP slots to provide 100M and GbE speeds for long-distance deployments.

Simple, intuitive wizard set up
For small businesses that want to manage their infrastructure in advance, the ZyXEL GS1900 Series comes with a friendly built-in Web-based browser for simple configuration and management. Moreover, the friendly step-by-step intuitive wizard helps avoiding multiple complicated configuration pages for quick set up with few clicks in the matter of minutes. To guide the users from start-up, VLAN, Guest VLAN to QoS setting, the ZyXEL Series offers four most common steps and combines them into a quick and easy setup wizard; which does not just save deployment time and efforts, but is also helpful especially for the non-IT staff.

Avoiding network errors with easy management

The ZyXEL GS1900 Series is equipped with advanced management features to make the network stable and secure: loop protection that prevents network flooding, dual images to provide a backup FW if one crashes and storm control to ensure network efficiency, friendly on/off DoS with simple click to enable/disable instead of several setup pages, while SSL ensures the management frames are well encrypted when the device is accessed. The GS1900 Series provides network error prevention features and integrated network security for reduced risk and improved data streaming.

Energy saving for IEEE 802.3az
As operating overheads such as electric bills increase constantly due to the arising green awareness, businesses have to avoid unnecessary energy waste. The built-in IEEE 802.3az Energy Efficient Ethernet (EEE) and more ZyXEL innovative green features of ZyXEL GS1900 Series can reduce energy consumption of Ethernet devices through multiple intelligent ways.

Product details

21
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Broadcast storm control Yes
Certification CE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP) CE, FCC, C-Tick, Class B (GS1900-8/16/24E) BSMI CNS13438
Copper ethernet cabling technology 10BASE-T, 100BASE-T, 1000BASE-T
Flow control support Yes
Form factor 1U
Gigabit Ethernet (copper) ports quantity 24
Harmonized System (HS) code 85176990
MAC address filtering Yes
Management protocols SNMP v1,v2,v3, RMON (1,2,3,9)
MIB support RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493
Networking standards IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Power supply included Yes
Product colour Black
Quality of Service (QoS) support Yes
Rate limiting Yes
Security algorithms 802.1x RADIUS
SFP module slots quantity 2
SSH/SSL support Yes
Switch type Managed

Logistics

EAN4718937609512
Unit of measure—
Weight—
Dimensions —
Dangerous goodsNo

Warranty

  • 12-month warranty on everything we sell.
  • Runs from the day your order is delivered.
  • Faults under normal use are repaired, replaced or refunded.
Read the warranty terms

Payment

  • Clearpay
  • Klarna
  • Visa and Mastercard, processed securely by Tyl by NatWest with 3D Secure.
  • PayPal — your PayPal balance or a saved card or bank account.
  • Clearpay, Klarna and Billie — pay later or in instalments, processed by Stripe.
  • No surcharge on any payment method; refunds go back to the way you paid.
Read the payment policy
Spread the cost
  • Clearpay
  • Klarna
    • Clearpay
    4 interest-free payments of £64.94 with Clearpay. Learn more
    • Klarna
    3 payments of £86.58 at 0% interest with Klarna. Learn more
    Businesses: pay in 30 days on invoice with Billie. Learn more

Choose at checkout. 18+, T&Cs apply, credit subject to status.

Return policy: Item can be returned in its original condition for a full refund within 14 days of receipt, with a free tracked Royal Mail return label. Read full return policy

Recently viewed