Roll over image to zoom in · Click to see full view
Product information
From the manufacturer
About this product
- Inbuilt 'awareness' of other zyxel units in your network
- Web GUI interface for centralised management
- One-click remote factory resets and power cycling
- No additional software required
Advanced smart managed switching
Minimise wasteful overpowering of devices and help your business save money and time whilst powering more devices with the GS1920 series.
Perfect for SMBs these smart managed switches are rich in L2 features and provide 375Watts over
Ethernet providing reliant and future-proof networking.
Zyxel's One Network (ZON) provides a free and easy-to-use tool to simplify configuration, management and troubleshooting of the switch allowing you to focus on your business priorities.
Zyxel's networking equipement comes with in-built 'awareness' of other Zyxel units in your network allowing for one-click remote factory resets and power cycling through Zyxel Smart Connect.
Intuitive web-based interface
Would you like access to L2 features such as LACP, advanced QoS, VLAN, ACL and multicast IGMP snooping, without learning complex command-line interface(CLI)? You can with the intuitive web-based interface.
Connect more devices with consumption mode
Maximise your 375W of total budget and connect more power-hungry devices. 'Consumption mode' allows for delivery of only the actual power required for more efficiency and better ROI for your business.
Hear the silence with Smart Fan
Silent and reliable switch operation ideal for the office environment, both desktop and rack mounted. The in-built smart fan is designed to automatically adjust speed based on device temperature. Smart Fan will be available on current models with a Firmware upgrade from January 2018 (v4.5).
Plug into the power of the Zyxel ONE network
Easily maintain your network in one FREE platform with the Zyxel One Network (ZON) tool. Instal, configure and discover switches, WLAN and gateways in your network with one-click. ZON Utility is a free of charge tool which has been downloaded by over 15,000 users to date.
Maximum flexibility for your Gig
Futureproof your network for growth with the The GS1920 series. Ideal for SMB deployments in multiple scenarios, the GS1920 series provides up to 28 Gigabit copper ports for 24-port models, and up to 6 Gigabit fiber ports for 48-port models.
Product details
40
| 10G support | No |
|---|---|
| Access Control List (ACL) | Yes |
| ARP inspection | Yes |
| Authentication | Guest VLAN, Port-based authentication |
| Authentication type | IEEE 802.1x, RADIUS |
| Basic switching RJ-45 Ethernet ports quantity | 44 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Combo SFP ports quantity | 4 |
| Copper ethernet cabling technology | 100BASE-TX, 1000BASE-T |
| CPU defense | Yes |
| DHCP features | DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client |
| Electromagnetic compatibility | FCC 15 A, CE A, BSMI EMC |
| Fiber ethernet cabling technology | 1000BASE-X |
| Fiber optic connector | SFP |
| Flow control support | Yes |
| Forwarding rate | 74 Mpps |
| IGMP snooping | Yes |
| IP-MAC-Port binding | Yes |
| LED indicators | Yes |
| MAC address filtering | Yes |
| MAC address table | 16000 entries |
| MIB support | RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293 |
| Multicast support | Yes |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Packet buffer memory | 1.5 MB |
| Password protection | Yes |
| Product colour | Black |
| Quality of Service (QoS) support | Yes |
| Queue scheduling algorithms | SPQ, WFQ, Weighted Round Robin (WRR) |
| Rack mounting | Yes |
| Rate limiting | Yes |
| Safety | LVD, BSMI |
| Security algorithms | 802.1x RADIUS, SNMP, SNMPv3 |
| SFP module slots quantity | 2 |
| Spanning tree protocol | Yes |
| Switching capacity | 100 Gbit/s |
| Switch type | Managed |
| System event log | Yes |
| Virtual LAN features | Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN |
| VLAN support | Yes |
Logistics
| EAN | 4718937601905 |
|---|---|
| Unit of measure | — |
| Weight | — |
| Dimensions | — |
| Dangerous goods | No |
Warranty
- 12-month warranty on everything we sell.
- Runs from the day your order is delivered.
- Faults under normal use are repaired, replaced or refunded.
Payment
- Visa and Mastercard, processed securely by Tyl by NatWest with 3D Secure.
- PayPal — your PayPal balance or a saved card or bank account.
- Clearpay, Klarna and Billie — pay later or in instalments, processed by Stripe.
- No surcharge on any payment method; refunds go back to the way you paid.
Spread the cost
- 4 interest-free payments of £78.24 with Clearpay. Learn more
- 3 payments of £104.31 at 0% interest with Klarna. Learn more
- Businesses: pay in 30 days on invoice with Billie. Learn more
Choose at checkout. 18+, T&Cs apply, credit subject to status.