‹ Back to products
Brand: Zyxel

GS1920-48HPv2

Zyxel GS1920-48HPv2 GS192048HPV2-GB0101F

10G support No
Access Control List (ACL) Yes
ARP inspection Yes
Authentication Guest VLAN, Port-based authentication
Authentication type IEEE 802.1x, RADIUS
Basic switching RJ-45 Ethernet ports quantity 44

About this item

A new-look smart managed switch with a refreshed design inside and out!The GS1920v2 series extends the success of the best-selling GS1920 series with a stylish new look and enables cloud manageability with Zyxel NebulaFlexTM technology.Manage it your way!The GS1920v2 series introduces Zyxel NebulaFlexTM, which...

View full product description

Product information

About this product

  • NebulaFlex™ gives you the flexibility to switch between standalone and our license-free Nebula cloud management
  • Nebula cloud management allows easy deployment real-time configurations and effortless access to all your cloud devices anytime
  • Using user-friendly web-based GUI to manage and set up the switch without learning complex CLI
  • Smart fan and fanless designs offer silent operations in your office
  • Check real-time status intuitively by cloud and PoE LED indicators

A new-look smart managed switch with a refreshed design inside and out!
The GS1920v2 series extends the success of the best-selling GS1920 series with a stylish new look and enables cloud manageability with Zyxel NebulaFlexTM technology.

Manage it your way!
The GS1920v2 series introduces Zyxel NebulaFlexTM, which allows you to easily switch between standalone mode and our license-free Nebula cloud management platform anytime with just a few simple clicks.

Maximum flexibility for your Gig
The GS1920v2 series is ideal for SMB deployment in multiple scenarios, with its unique port combinations futureproofing your network to ensure easy growth down the road.

Whisper-quiet operation
Smart fan and fanless designs for silent operation in your workplace.

Power more devices more easily

Provides 30W per port and a wide range of power budget options from 130W to 375W—ideal for denser PoE deployments.
Default consumption mode boosts efficiency by delivering the actual power required.

Zyxel ONE Network
Use the complimentary ZON Utility to configure and discover switches, WLANs, and gateways in your network with one click.

Designed for the long haul
A web smart managed switch with an enterprise-grade hardware design. Built-in state-of-the-art hardware technology brings high quality and robustness to SMB networks.

Product details

40
10G support No
Access Control List (ACL) Yes
ARP inspection Yes
Authentication Guest VLAN, Port-based authentication
Authentication type IEEE 802.1x, RADIUS
Basic switching RJ-45 Ethernet ports quantity 44
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Combo SFP ports quantity 4
Copper ethernet cabling technology 100BASE-TX, 1000BASE-T
DHCP features DHCP client, DHCP relay, DHCP snooping, DHCPv6 relay
Electromagnetic compatibility FCC 15 A, CE A, BSMI EMC
Fiber optic connector SFP
Flash memory 32 MB
Flow control support Yes
Forwarding rate 74 Mpps
IGMP snooping Yes
Internal memory 256 MB
IP-MAC-Port binding Yes
MAC address filtering Yes
MAC address table 16000 entries
Mean time between failures (MTBF) 502509 h
MIB support RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
Multicast support Yes
Networking standards IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
Noise level 26.5 dB
Packet buffer memory 1.5 MB
Product colour Black
Quality of Service (QoS) support Yes
Queue scheduling algorithms SPQ, WFQ, Weighted Round Robin (WRR)
Rack mounting Yes
Rate limiting Yes
Security algorithms 802.1x RADIUS, SNMP, SNMPv3
SFP module slots quantity 2
Spanning tree protocol Yes
Switching capacity 100 Gbit/s
Switch layer L2/L3/L4
Switch type Managed
System event log Yes
Virtual LAN features IP subnet–based VLAN, MAC address-based VLAN, Port-based VLAN, Private VLAN, Protocol-based VLAN, Voice VLAN
VLAN support Yes

Logistics

EAN4718937601981
Unit of measure—
Weight—
Dimensions —
Dangerous goodsNo

Warranty

  • 12-month warranty on everything we sell.
  • Runs from the day your order is delivered.
  • Faults under normal use are repaired, replaced or refunded.
Read the warranty terms

Payment

  • Clearpay
  • Klarna
  • Visa and Mastercard, processed securely by Tyl by NatWest with 3D Secure.
  • PayPal — your PayPal balance or a saved card or bank account.
  • Clearpay, Klarna and Billie — pay later or in instalments, processed by Stripe.
  • No surcharge on any payment method; refunds go back to the way you paid.
Read the payment policy
Spread the cost
  • Clearpay
  • Klarna
    • Clearpay
    4 interest-free payments of £146.08 with Clearpay. Learn more
    • Klarna
    3 payments of £194.78 at 0% interest with Klarna. Learn more
    Businesses: pay in 30 days on invoice with Billie. Learn more

Choose at checkout. 18+, T&Cs apply, credit subject to status.

Return policy: Item can be returned in its original condition for a full refund within 14 days of receipt, with a free tracked Royal Mail return label. Read full return policy

Recently viewed